Initial version
[tenra-roller.git] / buildozer.spec
1 [app]
2
3 # (str) Title of your application
4 title = TBZ Roller
5
6 # (str) Package name
7 package.name = tbzroller
8
9 # (str) Package domain (needed for android/ios packaging)
10 package.domain = uk.me.njae
11
12 # (str) Source code where the main.py live
13 source.dir = .
14
15 # (list) Source files to include (let empty to include all the files)
16 source.include_exts = py,png,jpg,kv,atlas
17
18 # (list) List of inclusions using pattern matching
19 #source.include_patterns = assets/*,images/*.png
20
21 # (list) Source files to exclude (let empty to not exclude anything)
22 #source.exclude_exts = spec
23
24 # (list) List of directory to exclude (let empty to not exclude anything)
25 #source.exclude_dirs = tests, bin
26
27 # (list) List of exclusions using pattern matching
28 #source.exclude_patterns = license,images/*/*.jpg
29
30 # (str) Application versioning (method 1)
31 version = 0.1
32
33 # (str) Application versioning (method 2)
34 # version.regex = __version__ = ['"](.*)['"]
35 # version.filename = %(source.dir)s/main.py
36
37 # (list) Application requirements
38 # comma seperated e.g. requirements = sqlite3,kivy
39 requirements = kivy
40
41 # (str) Custom source folders for requirements
42 # Sets custom source for any requirements with recipes
43 # requirements.source.kivy = ../../kivy
44
45 # (list) Garden requirements
46 #garden_requirements =
47
48 # (str) Presplash of the application
49 #presplash.filename = %(source.dir)s/data/presplash.png
50
51 # (str) Icon of the application
52 #icon.filename = %(source.dir)s/data/icon.png
53
54 # (str) Supported orientation (one of landscape, portrait or all)
55 orientation = landscape
56
57 # (list) List of service to declare
58 #services = NAME:ENTRYPOINT_TO_PY,NAME2:ENTRYPOINT2_TO_PY
59
60 #
61 # OSX Specific
62 #
63
64 #
65 # author = © Copyright Info
66
67 #
68 # Android specific
69 #
70
71 # (bool) Indicate if the application should be fullscreen or not
72 fullscreen = 1
73
74 # (list) Permissions
75 #android.permissions = INTERNET
76
77 # (int) Android API to use
78 #android.api = 19
79
80 # (int) Minimum API required
81 #android.minapi = 9
82
83 # (int) Android SDK version to use
84 #android.sdk = 20
85
86 # (str) Android NDK version to use
87 #android.ndk = 9c
88
89 # (bool) Use --private data storage (True) or --dir public storage (False)
90 #android.private_storage = True
91
92 # (str) Android NDK directory (if empty, it will be automatically downloaded.)
93 #android.ndk_path =
94
95 # (str) Android SDK directory (if empty, it will be automatically downloaded.)
96 #android.sdk_path =
97
98 # (str) ANT directory (if empty, it will be automatically downloaded.)
99 #android.ant_path =
100
101 # (str) python-for-android git clone directory (if empty, it will be automatically cloned from github)
102 #android.p4a_dir =
103
104 # (list) python-for-android whitelist
105 #android.p4a_whitelist =
106
107 # (bool) If True, then skip trying to update the Android sdk
108 # This can be useful to avoid excess Internet downloads or save time
109 # when an update is due and you just want to test/build your package
110 # android.skip_update = False
111
112 # (str) Android entry point, default is ok for Kivy-based app
113 #android.entrypoint = org.renpy.android.PythonActivity
114
115 # (list) List of Java .jar files to add to the libs so that pyjnius can access
116 # their classes. Don't add jars that you do not need, since extra jars can slow
117 # down the build process. Allows wildcards matching, for example:
118 # OUYA-ODK/libs/*.jar
119 #android.add_jars = foo.jar,bar.jar,path/to/more/*.jar
120
121 # (list) List of Java files to add to the android project (can be java or a
122 # directory containing the files)
123 #android.add_src =
124
125 # (str) python-for-android branch to use, if not master, useful to try
126 # not yet merged features.
127 #android.branch = master
128
129 # (str) OUYA Console category. Should be one of GAME or APP
130 # If you leave this blank, OUYA support will not be enabled
131 #android.ouya.category = GAME
132
133 # (str) Filename of OUYA Console icon. It must be a 732x412 png image.
134 #android.ouya.icon.filename = %(source.dir)s/data/ouya_icon.png
135
136 # (str) XML file to include as an intent filters in <activity> tag
137 #android.manifest.intent_filters =
138
139 # (list) Android additionnal libraries to copy into libs/armeabi
140 #android.add_libs_armeabi = libs/android/*.so
141 #android.add_libs_armeabi_v7a = libs/android-v7/*.so
142 #android.add_libs_x86 = libs/android-x86/*.so
143 #android.add_libs_mips = libs/android-mips/*.so
144
145 # (bool) Indicate whether the screen should stay on
146 # Don't forget to add the WAKE_LOCK permission if you set this to True
147 #android.wakelock = False
148
149 # (list) Android application meta-data to set (key=value format)
150 #android.meta_data =
151
152 # (list) Android library project to add (will be added in the
153 # project.properties automatically.)
154 #android.library_references =
155
156 # (str) Android logcat filters to use
157 #android.logcat_filters = *:S python:D
158
159 # (bool) Copy library instead of making a libpymodules.so
160 #android.copy_libs = 1
161
162 #
163 # iOS specific
164 #
165
166 # (str) Path to a custom kivy-ios folder
167 #ios.kivy_ios_dir = ../kivy-ios
168
169 # (str) Name of the certificate to use for signing the debug version
170 # Get a list of available identities: buildozer ios list_identities
171 #ios.codesign.debug = "iPhone Developer: <lastname> <firstname> (<hexstring>)"
172
173 # (str) Name of the certificate to use for signing the release version
174 #ios.codesign.release = %(ios.codesign.debug)s
175
176
177 [buildozer]
178
179 # (int) Log level (0 = error only, 1 = info, 2 = debug (with command output))
180 log_level = 1
181
182 # (int) Display warning if buildozer is run as root (0 = False, 1 = True)
183 warn_on_root = 1
184
185 # (str) Path to build artifact storage, absolute or relative to spec file
186 # build_dir = ./.buildozer
187
188 # (str) Path to build output (i.e. .apk, .ipa) storage
189 # bin_dir = ./bin
190
191 # -----------------------------------------------------------------------------
192 # List as sections
193 #
194 # You can define all the "list" as [section:key].
195 # Each line will be considered as a option to the list.
196 # Let's take [app] / source.exclude_patterns.
197 # Instead of doing:
198 #
199 #[app]
200 #source.exclude_patterns = license,data/audio/*.wav,data/images/original/*
201 #
202 # This can be translated into:
203 #
204 #[app:source.exclude_patterns]
205 #license
206 #data/audio/*.wav
207 #data/images/original/*
208 #
209
210
211 # -----------------------------------------------------------------------------
212 # Profiles
213 #
214 # You can extend section / key with a profile
215 # For example, you want to deploy a demo version of your application without
216 # HD content. You could first change the title to add "(demo)" in the name
217 # and extend the excluded directories to remove the HD content.
218 #
219 #[app@demo]
220 #title = My Application (demo)
221 #
222 #[app:source.exclude_patterns@demo]
223 #images/hd/*
224 #
225 # Then, invoke the command line with the "demo" profile:
226 #
227 #buildozer --profile demo android debug